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Attendance – Accruals – Troubleshoot  

 

Summary: 
Find the cause of bad accruals. 

 

Problem / Goal: 
Correct the way the program accrues Time-Off. 

Solution: 
1. Click File > Maintenance > Perform Accruals. A popup will 

open where you can see the last date on which accruals 

ran. Perhaps you simply need to run your accruals. If they 

have run through [today], move on to step 2.
 

 

2. Open the Calendar screen of an employee who’s balance is wrong. Click the Year Settings tab directly under the calendar. 
 

3. It is important to be mindful of when the [current year] began because there are three possibilities of when “this year” began.  

This year may have started on… 

 The last Anniversary of the employee or… 

 Last January 1
st  

or… 

 The date when the current Fiscal Year began 

Your bad balance could be due to the fact that the [year] has been set to start on the wrong date. If you find that this is the 

case, you will have to open the plan and change the Benefit Year setting. See Time-Off Accrual Plan Setup below.  

…However, if the [year] is already set to begin on the correct date, move on to step 3 below. 
 

4. Open the Category Assignments screen for that employee and note the “name” of the plan assigned to the employee.   

Is it the correct Plan?  

 

 If it is, move to the next bullet point. If not, assign the correct plan, save it. 

NOTE: 

Changing the assigned Time-off plan will [not] immediately correct the way that Time-Off accrued. Such changes are [not] 

retroactive. You will need to now go back and remove the accruals that took place incorrectly between now and some 

point in the past and re-run them forward from that previous date through “today”. See Re-run Time-Off Accruals below. 

 

 If the correct Time-Off plan has been assigned, see whether any Time-Off amount has been entered under Initial 

Balance Earned. If there has, you’ll want to check the Initial Date.  If the “year” of the Initial Date is… 

o The current Calendar Year or 

o The current Fiscal Year or 

o The current Anniversary Year… 

…it will count toward the limit of what may be accrued [this year] as set under Max Annual Earned in the Time-Off plan. 

 

 If the employee’s Initial Balance Earned is supposed to represent what the employee had available “prior” to the beginning 

of the current year, change the Initial Date to the last date of last year.  Note that the last date of last year might not be 

December 31
st
. The Time-Off plan might have been set to run on a Fiscal year basis or on an Anniversary Year basis.  

 

 If the employee’s Initial Balance Earned represents what was earned previously [this year] PLUS what was carried over 

from [last year], you’ll need to go to the Accrual plan and change the Max Annual Earn to zeros. This effectively removes 

any [limit] to the amount that [may] be earned but it does not allow employees to automatically earn more than they 

[should]. Doing this will allow what was earned (plus) what was carried to [not] stop the program from continuing to accrue 

automatically. 
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 If the employee has the wrong plan, assign him/her the correct plan.  If changes have been made you will need to re-run 

your accruals from the point in the past where they had accrued incorrectly through “today”.  See page 3 on how to re-

run your accruals. 

 

5. Open the Transactions screen with the tab selected that represents the particular type of Time-Off that failed to accrue 

properly.  Scroll down if necessary so that the last entry is visible.  View the data from bottom to top to see where things went 

wrong. 

 

6. Click Settings > Time-Off Plan Maintenance.  Click on the Time-Off plan that “this” person has and click Plan 

Description. Has the plan been set up properly?  *Refer to Accrual Plan Setup below for detailed instructions on setting up a 

plan. 

 

7. Click Detail and view it in detail to verify that it has been set up properly.  Edit as necessary and click Save. Click Plan 

Description again to verify that it has been set up properly.  If changes have been made you will need to re-run your accruals 

from the point in the past where they had accrued incorrectly through “today”.  See the instructional document Accruals- 

Rerunning. 

 

8. Click File > Maintenance > Perform Accrual. A pop-up will open.  In large font it will indicate… Accruals last performed on 

[a date].  The date indicated should be “today’s date”.  If the date is a date in the past, click Run Accrual.  When it is done 

click Post Accruals and then, click Close.  You do not need to preview because you can always go back and remove and 

rerun your accruals. See page 3 on how to re-run your accruals. 

 

9. Click Settings > Global Preferences.  Then, click the Attendance tab. Look to the right Accrual Schedule to see whether it 

has been set to… 

 Run,  lets the program “automatically” calculate whether or not to accrue Time-Off to anyone. 

 Remind, which means that the program will remind the user to run accruals every time the program is opened. 

 No Action, which means that the program will do nothing.  The user must run accruals manually.   

 

We recommend that it be set to Run, Daily and that every day of the week be checked.  This way, when the program is 

opened on any of the days that have been checked, the program will “automatically” calculate whether or not to accrue time to 

anyone.  If no one should get any time, no one will.  Only those individuals who should accrue time will. 

 

10. Click Help > About to get the “full” multi-digit version number.  Whenever communicating with Tech Support, always indicate 

this complete version number and the title of the program. 

 

11. If all settings look correct but your balances are still incorrect, run a Database Maintenance at the computer where the 

database is located.  From the desktop click Start > Programs > Gradience > Maintenance > DB Maintenance > Start. 

 

12. If the issue persists, contact Tech Support and let them know what you’ve done to this point.   

 

Time-Off Accrual Plan Setup 

1.   To create a plan click Settings, Time-Off Plan Maintenance.  Then, click New, enter a Plan Name. Depending on how recent 

your version is, the verbiage may differ. 

 On versions 11.0.1212.7 and earlier… 

Under Method: 

Time of Service means that earned Time-Off will be based on length of employment. 

Hours Worked means that earned Time-Off will be based on the number of hours worked. 

 

 On versions 11.0.1301.7 and later… 

Under Time-Off Based On: 

Hire Date means that earned Time-Off will be based on length of employment. 

Hours Worked means that earned Time-Off will be based on the number of hours worked. 
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2. Select the Benefit Year. When does your year begin? Depending on how recent your version is, the verbiage may differ. 

 On versions 11.0.1212.7 and earlier… 

On the 1
st
 (Calendar) means that your [year] starts on January 1

st 

Hire Date means that the [year] starts on each employee's anniversary 

Fiscal Date means that each year will begin on the Fiscal Date that was entered in Global Preferences. 

 

 On versions 11.0.1301.7 and later… 

Calendar Year / January 1
st
 means that your [year] starts on January 1

st
 

Anniversary of Hire Date means that the [year] starts on each employee's anniversary 

Fiscal Date means that each year will begin on the Fiscal Date that was entered in Global Preferences. 

 

NOTE: 

Any changes you make to the Benefit Year setting will [not] immediately correct the way that Time-Off accrued. Such changes 

are [not] retroactive. You will need to now go back and remove the accruals that took place incorrectly between now and some 

point in the past and re-run them forward from that previous date through “today”. See Re-run Time-Off Accruals below. 

 

3.     Select How Often to Accrue.  

 Daily 

 Weekly 

 Monthly – 12 times per year 

 Annually – Once per year 

 Custom Dates - Please refer to our Attendance_Accrue_ by Custom Dates instructions. 

 

4.    Select what to do with the prior year balance. (choose to carry over or not)   

   

 When set to Hire Date, the plan will either zero out or carry over at midnight before the employee’s anniversary. 

 When set to On the 1
st
 (Calendar), the plan will zero out or carry over at midnight December 31

st
. 

 When set to Fiscal year, the plan will zero out or carry over at midnight the day prior to your Fiscal Date. 

 

5.     Prorating is No if Benefit Year is set to Hire Date/Anniversary of Hire date because there will be no partial 

        months or partial years. 

 

With prorate set to Yes:  

If you accrue On the 1
st
 (Calendar), the first amount will earned will only be a percentage of the normal monthly amount based 

on the partial month or year the employee has worked up to that time.  

  

EXAMPLE:  An employee starts his/her employment on July 10
th
.  By the time August 1

st
 rolls around, he/she would have 

worked roughly 66% of the month of July and will therefore only accrue (earn) roughly 66% of the normal monthly amount that 

first time. 

6. Earning Levels Start on Benefit Year:  This enables an employee to begin earning the next higher amount at the beginning 

of the year that they reach their next level.   This is only available when accruing monthly.  To do this for annual accruals ask 

for Tech Support to send instructions. 

 

EXAMPLE:  A person earns 40 hrs of vacation per year Every January 1
st
 for the first five years and 80 hrs per year from 5 to 

ten years of service. They reach their fifth year anniversary in May of 2008.  Normally, they would not earn the new “higher” 

amount until the January that “follows” their fifth anniversary because the January “prior” to their anniversary, they had not yet 

been employed five years.  With this feature checked, they would earn 80 hrs on the January of the year of their fifth 

anniversary. 

 

7.     Max Annual Bank:  This option allows you to cap accumulated carry over.   

http://www.gradiencesupport.com/entries/20760011-Gradience-Attendance-Pro-Enterprise-Accrue-Time-Off-by-Custom-Dates
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EXAMPLE:  You may allow carry over (5 days) in the Max Annual Carry, but may want to cap “accumulated carryover” (20 

Days). Each year, the program would allow them to carry over 5, and then when this cap hits 20, it would stop carrying over.   

8.     Time Earned In:  We recommend all plans earn Time-Off by an increment that matches the Display Mode.  

  

9.     Level:  The levels are time frames during which employees earn increasingly higher amounts of Time-Off. 

 

10.   From Month:  This indicates the starting point for each level. 

 

11.   Up to Month:  This indicates the point up to which this amount of Time-Off will be accrued. 

 

12.   Days per month or Hours per year, etc:  This is the amount of hours or days earned each month or year.  

  

13.     Max Annual Earn:  The most Time-Off that one can earn [including] Initial Balance “Earned” for that year. 

 

IMPORTANT! If when setting up the program after the year has already begun you entered an amount on the 

Category Assignments screen under Initial Balance Earned and that amount was a [combination] of what would have 

been earned as of the Initial Date [PLUS] the amount that carried over from the previous year, enter zeros under Max 

Annual Earn.  This effectively eliminates any [limit] on what [may] be earned during the year but it will [not] allow 

employees to [automatically] exceed the amount of Time-Off they are [scheduled] to earn. 

 

If you don’t do this, the amount of carryover will [count toward] the limit of what may be [earned] this year, causing the 

employee to [earn] less than expected. It will [not] however, cause employees to earn too much Time-Off. 

 

14.     Max Annual Carry:  This refers to the most Time-Off that one can carry over from the previous year. 

 

15.     Max Balance Allowed:  This refers to the most that one may have at any time during that level. 

 

When finished, click the Plan Description button for a text of how this plan will function.  Compare it with your policy. If it is not 

consistent with your policy, click Detail and make whatever changes you need to make to align the plan with your policy. Be sure to 

save your changes.  

 

NOTE: 

Any changes you make to the Time-Off plan will [not] immediately correct the way that Time-Off accrued. Such changes are [not] 

retroactive. You will need to now go back and remove the accruals that took place incorrectly between now and some point in the 

past and re-run them forward from that previous date through “today”. See Re-run Time-Off Accruals below. 

  

 

Re-run Time-Off Accruals 

You can run accruals retroactively from any point in the past.  

1. First set be sure to prevent the program from [automatically] running accruals. Click Settings > Global Preferences > 

Attendance. Later, you can reset it to Run. Under [Accrual Schedule] click No Action > Save > OK > Close.  

 

2. Back up the database to preserve the data as is. Click File > Maintenance > Back up the database. 

 

3. Click on File, Maintenance and click Remove Transactions. 

 

4. In the Begin Date field, enter the date from which you wish to re-accrue. 

 

5. Enter the current date into the End Date field. 
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6. Click Run Process.  

 

7. When the removal is complete, click File, Maintenance, Perform Accruals. A new window will appear. 

 

8. Click on Run Accruals. 

 

9. When the accruals are complete, click Post Accruals. 

   

10. To verify your results, click Transactions. If you are not happy with the results, you always can remove the accruals, correct 

the plans and rerun them. 

 

11. Once you have re-run your Time-Off accruals successfully, we recommend you set the program to [automatically] accrue Time-

Off going forward. To do this, Click Settings > Global Preferences > Attendance. Under [Accrual Schedule] click Run > Save 

> OK > Close. Going forward, your program will automatically accrue Time-Off whenever the Time-off plans dictate. 
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